WordPress Upgrade - 2.6.5 to 2.7

公開日: 2008年12月12日金曜日 Upgrade WordPress

思いのほか手こずりました。
まぁ、原因は私にあるわけだけど;-p

MEから本家に変更した時点で、wp-config.php をきちんとしておくべきでした。

ま、いろいろと苦労したし書きたいことはあるんだけどもう疲れたからいいや;-p

以下のサイトを参考に、
サーバ移転完了 - Find Your Alter-Ego

wp-config.php内、
[php]mb_language('Japanese');
mb_internal_encoding('UTF-8');[/php]
じゃなくて
[php]define('DB_CHARSET', 'utf8');
define('DB_COLLATE', 'utf8');[/php]
で日本語化するとか。
それに伴う文字化け対応とか。

次に以下のサイトを参考に、
「WordPress標準ガイドブック」書籍サポートサイト » capabilities.phpのエラーが表示された場合

capabilities.phpのエラー対応とか。
capabilities.phpのエラー対応はME用なのを本家用に編集したりとか。
権限もME用だったので、2.7用の権限用のデータに差し替えたりとか。

ふぃー。
ま、今回これでwp-config.phpは2.7用のものを使ったので今後は問題ないでしょう。
…きっと;-p

//
そうそう。WP2.7にするとSimple Tagsが使えなくなったので、

WordPress › Support » [Plugin: Simple Tags] wp 2.7 ?

WordPress | 日本語 » WordPress 2.7 ベータ 2

この辺を参考に

wp-content/plugins/simple-tags の simple-tags.php
[php num=35]if ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false ) { [/php]
を
[php num=35]if ( strpos($wp_version, '2.5') !== false || strpos($wp_version, '2.6') !== false || strpos($wp_version, '2.7') !== false ) { [/php]
に変更して対応。

//

と思ったらSimple Tagsのバージョンがあがってたね。
  • ?±??G???g???[?d????u?b?N?}?[?N???A

2 件のコメント :

  1. こんにちは、はじめまして。
    記事引用ありがとうございます。
    自分の書いた記事が誰かの役に立ったのは初めてかも。
    ここのところblogが面倒になってきてたのですが
    ちょっとやる気が出てきました。

    というわけでこの記事を参考にWP2.7に
    アップグレードしてみようと思います(笑)

    返信削除
  2. > evianさん
    こんにちはー、はじめまして:-)
    本当に助かりましたー。実は文字化けでけっこう悩んでたので;
    WP2.7は管理画面ががらりと変わったのでちょっと新鮮です:-)
    でも記事投稿にはectoを使ってるんですけどね;-p
    今後ともよろしくお願いします〜。
    #ちなみにこのコメントは管理画面からの返信機能で:-]

    返信削除